Getting Started

Requirements

qiBuild is a set of command line tools written in Python .

Only Python 2.7 is supported.

Note that most linux distributions now comes with Python3 by default now, so you may need to install python 2 first.

Installation

Linux

Step Action

Install qibuild with pip .

It is recommended to install qibuild with the --user option, in order to keep your system clean.


                 
                  pip install qibuild --user

                 
                

Add $HOME/.local/bin to your $PATH .

One way to that is to add the following line at the end of your ~/.bashrc file:


                 
                  PATH=$PATH:$HOME/.local/bin

                 
                

Mac

Step Action

Install qibuild with pip .

It is recommended to install qibuild with the --user option, in order to keep your system clean.


                 
                  pip install qibuild --user

                 
                
Add $HOME/Library/Python/2.7/bin to your $PATH .

Windows

Step Action

Install qibuild with pip .


                 
                  pip install qibuild

                 
                
Add C:\Python27 and c:\Python27\Scripts in your PATH .
If you’d like to have nice colors in your console, you can install the Python readline library: http://pypi.python.org/pypi/pyreadline .