3 posts / 0 new
Last post
Offline
Last seen: 6 days 16 hours ago
Joined: January 9, 2018
NAO - "missing" skills
Hi all,Page 19 of the "First Steps" manual mentions various voice commands that I have seen successfully executed on YouTube videos.  However, some of these are not mentioned on the "Basic Channel - What can I say to NAO?" page.  Regardless, out of these NOT mentioned on that page, some like "What time is it?" and "How many degrees of freedom do you have" DO work anyway :)My question is about 4 of the commands mentioned on the "First Steps" manual (and seen on YouTube demos) that are NOT on the "Basic Channel - What can I say to NAO?" page AND do NOT seem to work:1. “Come to me” always yields “Sorry, I prefer not to move at the moment.”2. “Walk forward” always yields “Sorry, I prefer not to move at the moment.”3. “Point at me” always yields “I can’t see very well at the moment. I know where you are, but I can’t do that. Sorry.” (Note: Regardless of lighting, and despite "Walk towards the ball" and following my face always working).4. “Shake my hand” always yields “I don’t know how to do that yet.  We can wave “hello”. <then he waves>".Is there something wrong with my robot or were this skills removed at some point for some reason?Thanks,Steve
Offline
Last seen: 1 week 1 day ago
Joined: March 5, 2017
Trigger sentences are used in Autonomous Life to start behaviors on the robot. For example, "Follow me" should start the Follow Me behavior. However, if that behavior is not installed it may give a different response. The response may just be "sorry I can't do that" or it may be "I don't feel like moving" because there is a dialog that tells it to respond that way. There could be a few reasons for these responses. I don't know if SBR changed something for safety, there is a conflict or the app isn't installed. There may be a library that is not installed with the basic channel that should be... maybe try to contact customer support?
Offline
Last seen: 6 days 16 hours ago
Joined: January 9, 2018
Thanks for the reply :)  I am sure that I have the Basic Channel and all of its apps installed, as well as ALL the other apps in the App Store, so I do not think I am missing anything.  I just suspect that these behaviors have been removed for some reason.  As you suggested, I have an issue opened with Support.